Back to overview
Degraded

API + website degraded

Mar 06 at 11:19am PST
Affected services
api.firecrawl.dev
firecrawl.dev

Resolved
Mar 06 at 01:01pm PST

Root issues were found and addressed. We're back! We will continue to monitor our services.

Created
Mar 06 at 11:19am PST

We're investigating.